Androidサポートライブラリ-まったく同じバージョンと混合バージョン

Ωメガ

Android Studioでは、次の警告メッセージを処理しています。

すべてのcom.android.supportライブラリは、まったく同じバージョン仕様を使用する必要があります(バージョンを混在させると、ランタイムがクラッシュする可能性があります)。バージョン28.0.0-rc02、27.0.0が見つかりました。例には、com.android.support:animated-vector-drawable:28.0.0-rc02およびcom.android.support:support-media-compat:27.0.0が含まれます。

ここに画像の説明を入力してください

だから私はそれを修正しようと思った、私は追加する必要があります:

implementation 'com.android.support:support-media-compact:28.0.0-rc02'

しかし、そのようなバージョンはありません。でもやってみました28.0.0

解決に失敗しました:com.android.support:support-media-compact:28.0.0

私は何を間違っているのですか、そしてここで私の選択肢は何ですか?にダウングレードし27.0.0ますか?

私はそうしないことを望みます。

CommonsWare

試してみてください:

implementation 'com.android.support:support-media-compat:28.0.0-rc02'

一つだけありcではcompat

この記事はインターネットから収集されたものであり、転載の際にはソースを示してください。

侵害の場合は、連絡してくださいdebugcn@gmail.com

編集
0

コメントを追加

0

関連記事

分類Dev

Android ライブラリはまったく同じバージョンを使用する必要があります

分類Dev

モバイルポートレートとランドスケープのバージョンはまったく同じ

分類Dev

コンパイル 'com.android.support:multidex:1.0.1'が間違って発生しました:すべてのcomandroidサポートライブラリはまったく同じバージョンを使用する必要があります

分類Dev

Androidサポートライブラリのすべてのバージョンに同じリビジョン番号が付けられていますか?

分類Dev

AndroidGradleサポートライブラリは同じバージョンを使用する必要があります

分類Dev

すべてのcom.android.supportライブラリは、バージョン25.2.0、25.0.0で見つかったものとまったく同じバージョン仕様を使用する必要があります

分類Dev

Androidサポートライブラリのバージョンの競合

分類Dev

サポートライブラリバージョン

分類Dev

Android デザイン サポート ライブラリ - バージョン番号と Gradle エラー

分類Dev

すべてのgms / firebaseライブラリはまったく同じバージョンを使用する必要があります(バージョンを混在させるとランタイムクラッシュが発生する可能性があります)。見つかったバージョン16.1.1 16.0.1 16.0.0 15.0.1

分類Dev

すべてのgms / firebaseライブラリはまったく同じバージョンを使用する必要があります(バージョンを混在させるとランタイムクラッシュが発生する可能性があります)。見つかったバージョン16.1.1 16.0.1 16.0.0 15.0.1

分類Dev

すべてのcom.android.supportライブラリは、バージョンが同じであっても、まったく同じバージョン仕様を使用する必要があります

分類Dev

Android Studioはすべてのgms / firebaseライブラリでまったく同じバージョンを使用する必要があります

分類Dev

すべてのcom.android.supportライブラリは、まったく同じバージョン仕様を使用する必要があります

分類Dev

android.supportライブラリは、まったく同じバージョン仕様を使用する必要があります

分類Dev

すべてのcom.android.supportライブラリは、まったく同じバージョンを使用する必要があります

分類Dev

すべてのcom.android.supportライブラリは、まったく同じバージョン仕様を使用する必要があります

分類Dev

すべてのcom.android.supportライブラリは、まったく同じバージョン仕様を使用する必要があります:27.0.2

分類Dev

すべての com.google.android.gms ライブラリは、まったく同じバージョンを使用する必要があります

分類Dev

すべてのAndroidサポートライブラリは同じバージョン仕様を使用する必要があります

分類Dev

すべてのcom.android.supportライブラリは、まったく同じバージョン仕様を使用する必要があります。見つかったバージョン28.0.0、26.1.0

分類Dev

Android Studioは、間違ったバージョンのAndroidサポートライブラリを使用する傾向があります。

分類Dev

Android Gradle:すべてのgms / firebaseライブラリは、まったく同じバージョン仕様を使用する必要があります(バージョンを混在させると、ランタイムがクラッシュする可能性があります)

分類Dev

すべての com.android.support ライブラリは、まったく同じバージョン仕様を使用する必要があります (バージョンを混在させると、ランタイムがクラッシュする可能性があります)

分類Dev

すべての com.android.support ライブラリは、まったく同じバージョン仕様を使用する必要があります (バージョンが混在すると、ランタイムがクラッシュする可能性があります)

分類Dev

cloudantサーバーでのバージョンとライブラリのサポートは何ですか?

分類Dev

すべてのGMS / firebaseするライブラリはまったく同じバージョンを使用する必要があります。見つかったバージョン15.1.0、15.0.2、15.0.1、15.0.0。

分類Dev

同じAndroidプロジェクトの2つのAndroidモジュールが異なるサポートライブラリバージョンを使用するとどうなりますか?

分類Dev

android.support:appcompat-v7:25.2.0をコンパイルするとき、「すべてのcom.android.supportライブラリはまったく同じバージョン仕様を使用する必要があります」

Related 関連記事

  1. 1

    Android ライブラリはまったく同じバージョンを使用する必要があります

  2. 2

    モバイルポートレートとランドスケープのバージョンはまったく同じ

  3. 3

    コンパイル 'com.android.support:multidex:1.0.1'が間違って発生しました:すべてのcomandroidサポートライブラリはまったく同じバージョンを使用する必要があります

  4. 4

    Androidサポートライブラリのすべてのバージョンに同じリビジョン番号が付けられていますか?

  5. 5

    AndroidGradleサポートライブラリは同じバージョンを使用する必要があります

  6. 6

    すべてのcom.android.supportライブラリは、バージョン25.2.0、25.0.0で見つかったものとまったく同じバージョン仕様を使用する必要があります

  7. 7

    Androidサポートライブラリのバージョンの競合

  8. 8

    サポートライブラリバージョン

  9. 9

    Android デザイン サポート ライブラリ - バージョン番号と Gradle エラー

  10. 10

    すべてのgms / firebaseライブラリはまったく同じバージョンを使用する必要があります(バージョンを混在させるとランタイムクラッシュが発生する可能性があります)。見つかったバージョン16.1.1 16.0.1 16.0.0 15.0.1

  11. 11

    すべてのgms / firebaseライブラリはまったく同じバージョンを使用する必要があります(バージョンを混在させるとランタイムクラッシュが発生する可能性があります)。見つかったバージョン16.1.1 16.0.1 16.0.0 15.0.1

  12. 12

    すべてのcom.android.supportライブラリは、バージョンが同じであっても、まったく同じバージョン仕様を使用する必要があります

  13. 13

    Android Studioはすべてのgms / firebaseライブラリでまったく同じバージョンを使用する必要があります

  14. 14

    すべてのcom.android.supportライブラリは、まったく同じバージョン仕様を使用する必要があります

  15. 15

    android.supportライブラリは、まったく同じバージョン仕様を使用する必要があります

  16. 16

    すべてのcom.android.supportライブラリは、まったく同じバージョンを使用する必要があります

  17. 17

    すべてのcom.android.supportライブラリは、まったく同じバージョン仕様を使用する必要があります

  18. 18

    すべてのcom.android.supportライブラリは、まったく同じバージョン仕様を使用する必要があります:27.0.2

  19. 19

    すべての com.google.android.gms ライブラリは、まったく同じバージョンを使用する必要があります

  20. 20

    すべてのAndroidサポートライブラリは同じバージョン仕様を使用する必要があります

  21. 21

    すべてのcom.android.supportライブラリは、まったく同じバージョン仕様を使用する必要があります。見つかったバージョン28.0.0、26.1.0

  22. 22

    Android Studioは、間違ったバージョンのAndroidサポートライブラリを使用する傾向があります。

  23. 23

    Android Gradle:すべてのgms / firebaseライブラリは、まったく同じバージョン仕様を使用する必要があります(バージョンを混在させると、ランタイムがクラッシュする可能性があります)

  24. 24

    すべての com.android.support ライブラリは、まったく同じバージョン仕様を使用する必要があります (バージョンを混在させると、ランタイムがクラッシュする可能性があります)

  25. 25

    すべての com.android.support ライブラリは、まったく同じバージョン仕様を使用する必要があります (バージョンが混在すると、ランタイムがクラッシュする可能性があります)

  26. 26

    cloudantサーバーでのバージョンとライブラリのサポートは何ですか?

  27. 27

    すべてのGMS / firebaseするライブラリはまったく同じバージョンを使用する必要があります。見つかったバージョン15.1.0、15.0.2、15.0.1、15.0.0。

  28. 28

    同じAndroidプロジェクトの2つのAndroidモジュールが異なるサポートライブラリバージョンを使用するとどうなりますか?

  29. 29

    android.support:appcompat-v7:25.2.0をコンパイルするとき、「すべてのcom.android.supportライブラリはまったく同じバージョン仕様を使用する必要があります」

ホットタグ

アーカイブ