PIP Could not find any downloads that satisfy the requirement SQLAlchemy

Deepend
  • Ubuntu 12.04
  • Apache 2.2.22

pip has stopped working on my ubuntu server and gives the below error when I try to download anything.

$ sudo pip install SQLAlchemy
Downloading/unpacking SQLAlchemy
  Cannot fetch index base URL http://pypi.python.org/simple/
  Could not find any downloads that satisfy the requirement SQLAlchemy
No distributions at all found for SQLAlchemy
Storing complete log in /home/user/.pip/pip.log

All of the below also do not work

$ sudo pip install --upgrade pip 
$ sudo apt-get install build-essential

My /etc/environment has the below settings which were working previously.

http_proxy="http://myproxyhere:portnumberhere/"
HTTP_PROXY="http://myproxyhere:portnumberhere/"

My /home/user/.pip

------------------------------------------------------------
/usr/bin/pip run on Sat Jun  7 20:08:38 2014
Downloading/unpacking SQLAlchemy

  Getting page http://pypi.python.org/simple/SQLAlchemy
  Could not fetch URL http://pypi.python.org/simple/SQLAlchemy: <urlopen error [Errno 111] Connection refused>
  Will skip URL http://pypi.python.org/simple/SQLAlchemy when looking for download links for SQLAlchemy
  Getting page http://pypi.python.org/simple/
  Could not fetch URL http://pypi.python.org/simple/: <urlopen error [Errno 111] Connection refused>
  Will skip URL http://pypi.python.org/simple/ when looking for download links for SQLAlchemy
  Cannot fetch index base URL http://pypi.python.org/simple/

  URLs to search for versions for SQLAlchemy:
  * http://pypi.python.org/simple/SQLAlchemy/
  Getting page http://pypi.python.org/simple/SQLAlchemy/
  Could not fetch URL http://pypi.python.org/simple/SQLAlchemy/: <urlopen error [Errno 111] Connection refused>
  Will skip URL http://pypi.python.org/simple/SQLAlchemy/ when looking for download links for SQLAlchemy
  Could not find any downloads that satisfy the requirement SQLAlchemy

No distributions at all found for SQLAlchemy

Exception information:
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/pip/basecommand.py", line 126, in main
    self.run(options, args)
  File "/usr/lib/python2.7/dist-packages/pip/commands/install.py", line 223, in run
    requirement_set.prepare_files(finder, force_root_egg_info=self.bundle, bundle=self.bundle)
  File "/usr/lib/python2.7/dist-packages/pip/req.py", line 948, in prepare_files
    url = finder.find_requirement(req_to_install, upgrade=self.upgrade)
  File "/usr/lib/python2.7/dist-packages/pip/index.py", line 152, in find_requirement
    raise DistributionNotFound('No distributions at all found for %s' % req)
DistributionNotFound: No distributions at all found for SQLAlchemy

Has anyone got any idea what might be going wrong?

Ivo

You need to fetch pypi over HTTPS, not HTTP.

For some reason your pip is configured to retrieve from http://pypi.python.org/simple/ rather than https://pypi.python.org/simple/

Collected from the Internet

Please contact [email protected] to delete if infringement.

edited at
0

Comments

0 comments
Login to comment

Related

From Dev

Could not find any downloads that satisfy the requirement dateutil

From Dev

Could not find any downloads that satisfy the requirement django-1.6.1

From Dev

Could not find any downloads that satisfy the requirement mysql-connector-python

From Dev

Could not find any downloads that satisfy the requirement twython-django

From Dev

Pip "Could not find a that satisfies the requirement"

From Java

'pip install' fails for every package ("Could not find a version that satisfies the requirement")

From Dev

'pip install' fails for every package ("Could not find a version that satisfies the requirement")

From Dev

pip could not find a version that satisfies the requirement django==2.2.1

From Dev

PIP randomly fails 'Could not find a version that satisfies the requirement' with the same requirements.txt

From Java

Could not find a version that satisfies the requirement tensorflow

From Java

Could not find a version that satisfies the requirement <package>

From Dev

Could not find a version that satisfies the requirement tensorflow

From Dev

Could not find a version that satisfies the requirement in python

From Dev

Could not find a version that satisfies the requirement djangocms

From Dev

Pip install-couldn't find a version that satisfies the requirement

From Dev

OSX Brew Python "Could not find a version that satisfies the requirement pyopencv"

From Java

ERROR: Could not find a version that satisfies the requirement csv (from versions: none)

From Dev

Error : Could not find a version that satisfies the requirement webdriver (from versions: )

From Dev

docker ERROR: Could not find a version that satisfies the requirement apturl==0.5.2

From Dev

OSX Brew Python "Could not find a version that satisfies the requirement pyopencv"

From Dev

How to fix install error "Could not find a version that satisfies the requirement pyplot"?

From Dev

Could not find version that satisfies requirement in buildozer.spec file

From Dev

Capistrano -- Could not find *** in any of the sources

From Dev

Algorithm - Find all sets that satisfy any combination of the input elements

From Dev

Could not find bcrypt-3.1.7 in any of the sources

From Dev

Elastic Beanstalk could not find any platforms

From Dev

Could not find byebug-3.5.1 in any of the sources

From Dev

Could not find ffi-1.9.4 in any of the sources

From Dev

Maven and Vaadin plugin could not find any themes

Related Related

  1. 1

    Could not find any downloads that satisfy the requirement dateutil

  2. 2

    Could not find any downloads that satisfy the requirement django-1.6.1

  3. 3

    Could not find any downloads that satisfy the requirement mysql-connector-python

  4. 4

    Could not find any downloads that satisfy the requirement twython-django

  5. 5

    Pip "Could not find a that satisfies the requirement"

  6. 6

    'pip install' fails for every package ("Could not find a version that satisfies the requirement")

  7. 7

    'pip install' fails for every package ("Could not find a version that satisfies the requirement")

  8. 8

    pip could not find a version that satisfies the requirement django==2.2.1

  9. 9

    PIP randomly fails 'Could not find a version that satisfies the requirement' with the same requirements.txt

  10. 10

    Could not find a version that satisfies the requirement tensorflow

  11. 11

    Could not find a version that satisfies the requirement <package>

  12. 12

    Could not find a version that satisfies the requirement tensorflow

  13. 13

    Could not find a version that satisfies the requirement in python

  14. 14

    Could not find a version that satisfies the requirement djangocms

  15. 15

    Pip install-couldn't find a version that satisfies the requirement

  16. 16

    OSX Brew Python "Could not find a version that satisfies the requirement pyopencv"

  17. 17

    ERROR: Could not find a version that satisfies the requirement csv (from versions: none)

  18. 18

    Error : Could not find a version that satisfies the requirement webdriver (from versions: )

  19. 19

    docker ERROR: Could not find a version that satisfies the requirement apturl==0.5.2

  20. 20

    OSX Brew Python "Could not find a version that satisfies the requirement pyopencv"

  21. 21

    How to fix install error "Could not find a version that satisfies the requirement pyplot"?

  22. 22

    Could not find version that satisfies requirement in buildozer.spec file

  23. 23

    Capistrano -- Could not find *** in any of the sources

  24. 24

    Algorithm - Find all sets that satisfy any combination of the input elements

  25. 25

    Could not find bcrypt-3.1.7 in any of the sources

  26. 26

    Elastic Beanstalk could not find any platforms

  27. 27

    Could not find byebug-3.5.1 in any of the sources

  28. 28

    Could not find ffi-1.9.4 in any of the sources

  29. 29

    Maven and Vaadin plugin could not find any themes

HotTag

Archive