如何强制gradle使用特定的appcompat-v7版本?

StackOverflower

在我的gradle文件中我有这个

dependencies {
    testCompile 'junit:junit:4.12'
    compile 'com.android.support:appcompat-v7:23.0.0'
    compile 'com.android.support:design:23.0.0'
            ...
}

但是然后,运行时gradle dependencies我看到类似这样的东西

+--- com.android.support:appcompat-v7:23.0.0 -> 23.1.1
|    \--- com.android.support:support-v4:23.1.1

可能表明它正在自动使用23.1.1这会导致依赖的库出现问题23.0.0我收到这样的错误

错误:找不到符号变量dialog_fixed_height_major

错误:找不到符号变量dialog_fixed_height_minor

错误:找不到符号变量dialog_fixed_width_major

错误:找不到符号变量dialog_fixed_width_minor

错误:找不到符号变量RtlOverlay_Widget_AppCompat_ActionButton_Overflow

这是因为这些符号在版本23.1.0中删除

我该如何强制gradle构建筹码,23.0.0以便使依赖关系变得快乐?

吸血鬼

“问题”是Gradles解决冲突的策略。您具有的某些依赖项取决于该库的较新版本。如果您在的输出中向下滚动dependencies,则会看到哪个。

Gradle的默认解析策略是采用最新的请求版本。您可以更改它以使构建失败,这意味着您必须手动解决所有版本冲突。但是,如果您有依赖于较新版本的内容,那么问题是它是否可以与较旧版本一起使用。

您可以在Gradle用户指南中阅读有关冲突解决的更多信息

本文收集自互联网,转载请注明来源。

如有侵权,请联系[email protected] 删除。

编辑于
0

我来说两句

0条评论
登录后参与评论

相关文章

来自分类Dev

将Android.Support Library v7 AppCompat更新到21.0.3版本后出错

来自分类Dev

无法使用版本20以下的ACompat v7

来自分类Dev

使用appcompat v7的更高版本的设备忽略了Android操作栏样式

来自分类Dev

setSupportProgressBarIndeterminateVisibility引发NPE(支持V7版本21.0.1)

来自分类Dev

setSupportProgressBarIndeterminateVisibility引发NPE(支持V7版本21.0.1)

来自分类Dev

如何使用appcompat v7压缩后的SearchView折叠?

来自分类Dev

如何滑动以删除卡(使用appcompat v7的CardView)

来自分类Dev

如何强制特定依赖项在Gradle中使用特定版本的库

来自分类Dev

我如何知道升级到Windows 10之前的Windows 7版本

来自分类Dev

如何修复Nexus 3.0(Milestone 7版本)的init.d脚本

来自分类Dev

何时在Sitecore 7版本中绝对在Lucene上使用SOLR?

来自分类Dev

如何激活gcc 4.7版本?

来自分类Dev

如何激活gcc 4.7版本?

来自分类Dev

Android支持库v7 appcompat

来自分类Dev

使用Appcompat v7的自定义EditText样式

来自分类Dev

如何“强制” python使用模块的特定版本?

来自分类Dev

如何使用appcompat v7创建卡片工具栏

来自分类Dev

如何使用AppCompat v7在Android中自定义EditText字段:21

来自分类Dev

如何获得特定的Windows 10版本?

来自分类Dev

在已安装的sdk 21版本上使用appcompat以前的版本

来自分类Dev

iPython使用2.6版本而不是2.7版本

来自分类Dev

Coderunner使用旧的2.71版本的Python代替OSX 10.7.5上的3.2版本

来自分类常见问题

如何使IntelliJ scala项目使用Scala 2.9.2版本?

来自分类Dev

如何使IntelliJ scala项目使用Scala 2.9.2版本?

来自分类Dev

如何使用rand-C99版本

来自分类Dev

如何使用CMake查找32位版本的zlib

来自分类Dev

Yii生成jQuery 1.71版。我如何强制yii使用特定的jQuery版本

来自分类Dev

如何判断已安装了哪个PHP 7版本,以及如何将其更新到最新版本?

来自分类Dev

安装多个版本时,如何强制jekyll使用特定版本?

Related 相关文章

  1. 1

    将Android.Support Library v7 AppCompat更新到21.0.3版本后出错

  2. 2

    无法使用版本20以下的ACompat v7

  3. 3

    使用appcompat v7的更高版本的设备忽略了Android操作栏样式

  4. 4

    setSupportProgressBarIndeterminateVisibility引发NPE(支持V7版本21.0.1)

  5. 5

    setSupportProgressBarIndeterminateVisibility引发NPE(支持V7版本21.0.1)

  6. 6

    如何使用appcompat v7压缩后的SearchView折叠?

  7. 7

    如何滑动以删除卡(使用appcompat v7的CardView)

  8. 8

    如何强制特定依赖项在Gradle中使用特定版本的库

  9. 9

    我如何知道升级到Windows 10之前的Windows 7版本

  10. 10

    如何修复Nexus 3.0(Milestone 7版本)的init.d脚本

  11. 11

    何时在Sitecore 7版本中绝对在Lucene上使用SOLR?

  12. 12

    如何激活gcc 4.7版本?

  13. 13

    如何激活gcc 4.7版本?

  14. 14

    Android支持库v7 appcompat

  15. 15

    使用Appcompat v7的自定义EditText样式

  16. 16

    如何“强制” python使用模块的特定版本?

  17. 17

    如何使用appcompat v7创建卡片工具栏

  18. 18

    如何使用AppCompat v7在Android中自定义EditText字段:21

  19. 19

    如何获得特定的Windows 10版本?

  20. 20

    在已安装的sdk 21版本上使用appcompat以前的版本

  21. 21

    iPython使用2.6版本而不是2.7版本

  22. 22

    Coderunner使用旧的2.71版本的Python代替OSX 10.7.5上的3.2版本

  23. 23

    如何使IntelliJ scala项目使用Scala 2.9.2版本?

  24. 24

    如何使IntelliJ scala项目使用Scala 2.9.2版本?

  25. 25

    如何使用rand-C99版本

  26. 26

    如何使用CMake查找32位版本的zlib

  27. 27

    Yii生成jQuery 1.71版。我如何强制yii使用特定的jQuery版本

  28. 28

    如何判断已安装了哪个PHP 7版本,以及如何将其更新到最新版本?

  29. 29

    安装多个版本时,如何强制jekyll使用特定版本?

热门标签

归档