Install only one package from package.json?

Anton Rudeshko

Suppose that somewhere in my package.json I have:

"dependencies": {
    "bower": "1.0.0",
    // zillion other dependencies
}

Is there a way to make npm install only [email protected] from my package.json? Like so: npm install --only bower.

My goal is to make npm install and bower install run simultaneously.

Anton Rudeshko

As a workaround you may use something like:

> node -p -e "require('./package.json').dependencies.bower"
// → 1.0.0
> npm install [email protected]`node -p -e "require('./package.json').dependencies.bower"`
// → npm install [email protected]

Where -e/--eval flag evaluates passed string and -p/--print prints result of eval.

本文收集自互联网,转载请注明来源。

如有侵权,请联系[email protected] 删除。

编辑于
0

我来说两句

0条评论
登录后参与评论

相关文章

来自分类Dev

Unable to install XML package in R on CentOS

来自分类Dev

ACTION_INSTALL_PACKAGE

来自分类Dev

为什么在“ npm install express”之后我的目录中没有package.json?

来自分类Dev

java importing from the same package

来自分类Dev

如何使用package.json和npm install安装bower?

来自分类Dev

Observe package from polymer dart

来自分类Dev

package.json与“ npm install%s -g”

来自分类Dev

Unable to install cachem package for R

来自分类Dev

npm install packagename --save-dev不更新package.json

来自分类Dev

npm install与编辑package.json和npm更新

来自分类Dev

Install local dist package into virtualenv

来自分类Dev

“ npm install [package]”不会更新package.json

来自分类Dev

npm install不会将依赖项保存到package.json

来自分类Dev

`npm install`在node:10.21.0-jessie-slim Dockerimage上的package-lock.json失败

来自分类Dev

--only = dev在package.json中是什么意思?

来自分类Dev

npm install不会在react应用程序中修改package.json

来自分类Dev

'pip install <package>'和'python -m pip install <package>'有什么区别?

来自分类Dev

npm install无法读取package.json

来自分类Dev

为什么在“ npm install express”之后我的目录中没有package.json?

来自分类Dev

package.json与“ npm install%s -g”

来自分类Dev

创建了一个package.json文件,但是在运行npm install时出现依赖错误

来自分类Dev

安装package.json

来自分类Dev

为什么`npm install`与此特定的`package.json`挂在一起?

来自分类Dev

流星packages.json或package.json

来自分类Dev

键入package是否需要版本与package.json相同

来自分类Dev

Is there any way to install a transient package?

来自分类Dev

为什么我的 package.json 没有被 npm install 更新?

来自分类Dev

Package.json 脚本错误“缺少脚本:package-mac”

来自分类Dev

我的容器没有找到 package.json 来在 docker-compose 上执行 npm install

Related 相关文章

  1. 1

    Unable to install XML package in R on CentOS

  2. 2

    ACTION_INSTALL_PACKAGE

  3. 3

    为什么在“ npm install express”之后我的目录中没有package.json?

  4. 4

    java importing from the same package

  5. 5

    如何使用package.json和npm install安装bower?

  6. 6

    Observe package from polymer dart

  7. 7

    package.json与“ npm install%s -g”

  8. 8

    Unable to install cachem package for R

  9. 9

    npm install packagename --save-dev不更新package.json

  10. 10

    npm install与编辑package.json和npm更新

  11. 11

    Install local dist package into virtualenv

  12. 12

    “ npm install [package]”不会更新package.json

  13. 13

    npm install不会将依赖项保存到package.json

  14. 14

    `npm install`在node:10.21.0-jessie-slim Dockerimage上的package-lock.json失败

  15. 15

    --only = dev在package.json中是什么意思?

  16. 16

    npm install不会在react应用程序中修改package.json

  17. 17

    'pip install <package>'和'python -m pip install <package>'有什么区别?

  18. 18

    npm install无法读取package.json

  19. 19

    为什么在“ npm install express”之后我的目录中没有package.json?

  20. 20

    package.json与“ npm install%s -g”

  21. 21

    创建了一个package.json文件,但是在运行npm install时出现依赖错误

  22. 22

    安装package.json

  23. 23

    为什么`npm install`与此特定的`package.json`挂在一起?

  24. 24

    流星packages.json或package.json

  25. 25

    键入package是否需要版本与package.json相同

  26. 26

    Is there any way to install a transient package?

  27. 27

    为什么我的 package.json 没有被 npm install 更新?

  28. 28

    Package.json 脚本错误“缺少脚本:package-mac”

  29. 29

    我的容器没有找到 package.json 来在 docker-compose 上执行 npm install

热门标签

归档