如何将现有ionic2项目更新到ionic2 CLI的2.1.18版本

卡马尔·帕里瓦(Kamal Paliwal)

我已经将ionic2 CLI从2.1.17更新到了2.1.18,所以我应该如何升级使用2.1.17版本构建的现有项目。

这是离子信息的详细信息-您的系统信息:

Cordova CLI:6.4.0 Ionic CLI版本:2.1.18 Ionic App Lib版本:2.1.9 ios-deploy版本:未安装ios-sim版本:未安装OS:Linux 4.4节点版本:v6.9.2 Xcode版本:未安装

package.json

{
  "name": "ionic-hello-world",
  "author": "Ionic Framework",
  "homepage": "http://ionicframework.com/",
  "private": true,
  "scripts": {
    "ionic:build": "ionic-app-scripts build",
    "ionic:serve": "ionic-app-scripts serve"
  },
  "dependencies": {
    "@angular/common": "2.1.1",
    "@angular/compiler": "2.1.1",
    "@angular/compiler-cli": "2.1.1",
    "@angular/core": "2.1.1",
    "@angular/forms": "2.1.1",
    "@angular/http": "2.1.1",
    "@angular/platform-browser": "2.1.1",
    "@angular/platform-browser-dynamic": "2.1.1",
    "@angular/platform-server": "2.1.1",
    "@ionic/storage": "1.1.6",
    "ionic-angular": "2.0.0-rc.3",
    "ionic-native": "2.2.3",
    "ionicons": "3.0.0",
    "rxjs": "5.0.0-beta.12",
    "zone.js": "0.6.26"
  },
  "devDependencies": {
    "@ionic/app-scripts": "0.0.45",
    "typescript": "2.0.6"
  },
  "cordovaPlugins": [
    "cordova-plugin-statusbar",
    "cordova-plugin-device",
    "cordova-plugin-console",
    "cordova-plugin-whitelist",
    "cordova-plugin-splashscreen",
    "ionic-plugin-keyboard"
  ],
  "cordovaPlatforms": [],
  "description": "ionic: An Ionic project"
}
苏拉杰·饶

您的Ionic CLI版本已更新。您的项目使用的是Ionic 2 RC3(基于"ionic-angular": "2.0.0-rc.3",),而不是2.1.7。您当前的项目应该仍然有效。

如果要将项目升级到当前的RC4版本,最快的方法是查看ionic入门模板的package.json文件相应地更新您的package.json。删除您的node_modules文件夹。终于跑了

npm install

检查自述文件

另一种方法是简单地执行此操作,ionic start myApp blank --v2并用src文件夹替换src文件夹,并添加上一个项目中具有的任何其他软件包。

本文收集自互联网,转载请注明来源。

如有侵权,请联系[email protected] 删除。

编辑于
0

我来说两句

0条评论
登录后参与评论

相关文章

来自分类Dev

.Net 2版本的Element At

来自分类Dev

.Net 2版本的Element At

来自分类Dev

我可以将Ionic CLI和Cordova的当前版本用于ionic-1项目吗?

来自分类Dev

无法将Google字体应用于Ionic2项目

来自分类Dev

将bzip2版本信息写入文件

来自分类Dev

Ionic Build iOS和Xcode Build未部署最新的Ionic 2 Beta 10版本

来自分类Dev

Ionic Build iOS和Xcode Build未部署最新的Ionic 2 Beta 10版本

来自分类Dev

grub2是1.99版本的grub吗?

来自分类Dev

Spring Boot H2版本警告

来自分类Dev

DB2版本的SQL差异

来自分类Dev

水豚和Select2版本4

来自分类Dev

升级到xcode 6 beta 2版本

来自分类Dev

appengine上的Jinja2版本2.8

来自分类Dev

相同MDF文件的C#2版本

来自分类Dev

grub2是1.99版本的grub吗?

来自分类Dev

appengine上的Jinja2版本2.8

来自分类Dev

相同MDF文件的C#2版本

来自分类Dev

如何将数据传递给select2版本> 4.0

来自分类Dev

Python2“在一个文件中提高e [0],e [1],e [2]”和python3版本

来自分类Dev

如何使用Eclipse版本:Mars.1版本(4.5.1)创建Servlet?

来自分类Dev

向ionic2项目添加js库(尚未输入)

来自分类Dev

如何使用宏将现有数据从 Sheet1 更新到 Sheet2?

来自分类Dev

如何将 angular 2 或更高版本的项目更新到最新版本?

来自分类Dev

更新ember-cli 2.11.0版本后如何以npm代替bower?

来自分类Dev

Ionic2最低iOS和Android版本

来自分类Dev

PM2版本的Nodejs版本依赖性

来自分类Dev

Ionic2与流星

来自分类Dev

使用ionic 2 CLI创建ionic 1.x应用

来自分类Dev

获取FW / 1版本信息