如何安装libc6版本> = 2.29?

水银0114

当我打字

sudo apt-get install r-base-core

我收到以下错误

The following packages have unmet dependencies. r-base-core : Depends: libc6 (>= 2.29) but 2.27-3ubuntu1 is to be installed

据我了解,libc6现在是一个重要的库,不应删除。

那么如何从当前版本(2.27)升级到> = 2.29的任何版本?

ing

据我所知,libc6 2.29是最新版本。它可用于Ubuntu 19.04(链接)。

如果要安装libc6 amd64,请打开此链接进行下载,然后在终端中打开下载文件夹并运行sudo dpkg -i libc6_2.29-0ubuntu2_amd64.deb

如果要安装libc6 i386,可以从此链接下载它,然后在终端中打开下载文件夹并运行sudo dpkg -i libc6_2.29-0ubuntu2_i386.deb



编辑06/01/2020:
到目前为止,libc6_2.29不再存在。但是,可以通过此 链接 使用libc6_2.30和lib6_2.31 (2.31是Ubuntu 20.04的正式版本)。
如果您要下载的版本与Ubuntu版本所支持的官方版本不同(例如,版本2.27为18.04,版本2.30为Ubuntu 19.10 ...),请选中 此链接,
下载适合您的版本,然后打开下载文件夹并运行 sudo dpkg -i <the_file_name>

本文收集自互联网,转载请注明来源。

如有侵权,请联系[email protected] 删除。

编辑于
0

我来说两句

0条评论
登录后参与评论

相关文章

Related 相关文章

热门标签

归档