如何使IntelliJ scala项目使用Scala 2.9.2版本?

忘了卡玛

我正在尝试从scala文件创建jar文件-该文件将用于Scalatron机器人(http://scalatron.github.io/

问题是,如果我使用新的Scala 2.10-2.13版本(这些是InteliJJ允许我使用的唯一版本)创建jar文件,则scalatron bot无法正常工作。但是我发现降级到scala 2.9.2可以解决问题(使Scalatron正常工作(操作码有问题))。

如何在Intellij上降级到2.9.2?

呼叫

SBT与完全集成IntelliJ Idea,因此您可以在其中创建一个SBT项目IntlliJ自己构建build.sbt文件,然后将所需的scala版本放入其中,然后进行编译,打包和执行SBT

name := "scalatron"

version := "0.1"

scalaVersion := "2.9.2"

libraryDependencies += "org.scalatest" %% "scalatest" % "3.2.0-SNAP3" % Test

本文收集自互联网,转载请注明来源。

如有侵权,请联系[email protected] 删除。

编辑于
0

我来说两句

0条评论
登录后参与评论

相关文章

Related 相关文章

热门标签

归档