如何使IntelliJ scala项目使用Scala 2.9.2版本?

忘了卡玛

我正在尝试从scala文件创建jar文件-该文件将用于Scalatron机器人(http://scalatron.github.io/

问题是,如果我使用新的Scala 2.10-2.13版本(这些是InteliJJ允许我使用的唯一版本)创建jar文件,则scalatron bot无法正常工作。但是我发现降级到scala 2.9.2可以解决问题(使Scalatron正常工作(操作码有问题))。

如何在Intellij上降级到2.9.2?

呼叫

SBT与完全集成IntelliJ Idea,因此您可以在其中创建SBT项目IntlliJ自己构建build.sbt文件,并在其中放入所需的scala版本,并使用以下版本进行编译,打包和执行SBT

name := "scalatron"

version := "0.1"

scalaVersion := "2.9.2"

libraryDependencies += "org.scalatest" %% "scalatest" % "3.2.0-SNAP3" % Test

本文收集自互联网,转载请注明来源。

如有侵权,请联系[email protected] 删除。

编辑于
0

我来说两句

0条评论
登录后参与评论

相关文章

来自分类常见问题

如何使IntelliJ scala项目使用Scala 2.9.2版本?

来自分类Dev

如何使用打字稿检查Angular2版本

来自分类Dev

如何使用将在python2和python3版本中兼容的六模块迁移代码

来自分类Dev

如何将现有ionic2项目更新到ionic2 CLI的2.1.18版本

来自分类Dev

如何获得iOS 9版本模拟器?

来自分类Dev

如何在SuiteScript 2.0版本中使用带有NVAL2函数的“筛选条件”作为公式日期字段来创建搜索

来自分类Dev

如何将数据传递给select2版本> 4.0

来自分类Dev

如何在Maven中指定avro-mapred的hadoop2版本?

来自分类Dev

如何从npm或jspm下载angular2版本候选

来自分类Dev

如何在Tensorflow 2中解码示例(从1.12版本移植)

来自分类Dev

如何在jaxb2-maven-plugin 2.5.0版本中排除情节文件的生成?

来自分类Dev

如何在Ubuntu 12.04 LTS上安装最新的grub2版本

来自分类Dev

如何从npm或jspm下载angular2版本候选

来自分类Dev

.Net 2版本的Element At

来自分类Dev

.Net 2版本的Element At

来自分类Dev

Intellij Idea 14.0.3版本139.117(无法重建项目)

来自分类Dev

Win10升级到20H2版本失败——如何确定原因?

来自分类Dev

如何使用build.sbt(不是Build.scala)将SecureSocial添加到Play 2.x项目

来自分类Dev

Scala Specs2(3.x版)-如何创建和使用通告程序?

来自分类Dev

如何使用rand-C99版本

来自分类Dev

如何使用CMake查找32位版本的zlib

来自分类Dev

grub2是1.99版本的grub吗?

来自分类Dev

Spring Boot H2版本警告

来自分类Dev

DB2版本的SQL差异

来自分类Dev

水豚和Select2版本4

来自分类Dev

升级到xcode 6 beta 2版本

来自分类Dev

appengine上的Jinja2版本2.8

来自分类Dev

相同MDF文件的C#2版本

来自分类Dev

grub2是1.99版本的grub吗?

Related 相关文章

热门标签

归档