通过Heroku部署Rails应用程序使用旧版本的Node

Cepheaus C

尝试通过Ubuntu 16.04计算机上的Heroku“ git push heroku master”部署Rails应用程序时,出现以下错误:

[2/4] Fetching packages...
remote:          error @rails/webpa[email protected]: The engine "node" is incompatible with this module. Expected version ">=8.16.0".
remote:        error An unexpected error occurred: "Found incompatible module".
remote:        info If you think this is a bug, please open a bug report with the information provided in "/tmp/build_c472d4366cfa53133fe29a2426a45a7b/yarn-error.log".
remote:        info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.
remote:
remote:  !
remote:  !     Precompiling assets failed.
remote:  !
remote:  !     Push rejected, failed to compile Ruby app.
remote:
remote:  !     Push failed

这是我的package.json文件(在根文件夹中):

{
  "name": "site",
  "private": true,
  "dependencies": {
    "@rails/webpacker": "4.2.2",
    "flatpickr": "^4.6.3",
    "jquery": "^3.3.1",
    "node": "^12.x",
    "node-sass": "^4.13.1",
    "reading-time": "^1.2.0",
    "simple-lightbox": "^2.1.0"
  },
  "devDependencies": {
    "@babel/plugin-syntax-dynamic-import": "^7.8.3",
    "webpack-cli": "^3.3.11",
    "webpack-dev-server": "^3.10.3"
  }
}

节点--version:

v13.10.1

heroku运行节点--version:

Running node --version on ⬢ -site... up, run.4229 (Hobby)
v12.16.1
Cepheaus C

不确定确切是什么,但是问题与我使用的Heroku buildpack有关(heroku-buildpack-bundler2)

这是我为解决该问题所做的工作:

$ heroku buildpacks:set heroku/ruby
$ heroku buildpacks:add --index 1 heroku/nodejs

$ git push heroku master

现在一切正常:-)

本文收集自互联网,转载请注明来源。

如有侵权,请联系[email protected] 删除。

编辑于
0

我来说两句

0条评论
登录后参与评论

相关文章

来自分类Dev

部署后,Rails 4 Capistrano仍使用旧版本

来自分类Dev

禁用旧版本iPhone的iPhone应用程序

来自分类Dev

如何解决Flutter警告:您的Flutter应用程序是使用旧版本创建的

来自分类Dev

使用旧版本的jHipster

来自分类Dev

允许使用旧版本的python

来自分类Dev

活动使用旧版本的 Firefox

来自分类Dev

通过处置旧版本重新启动应用程序

来自分类Dev

对旧版本的iPhone禁用iPhone应用程序

来自分类Dev

应用程序尝试加载旧版本

来自分类Dev

iTunes Connect旧版本的应用程序

来自分类Dev

更新我的应用程序的旧版本

来自分类Dev

使用新的应用程序图标安装新版本的应用程序后,应用程序显示旧版本的应用程序图标

来自分类Dev

Chrome扩展程序升级后,用户仍可以使用旧版本吗?

来自分类Dev

强制使用旧版本的vuejs devtools或下载旧版本

来自分类Dev

无法使用旧版本的iReport打开Jasper报告

来自分类Dev

如何为Ruby项目使用旧版本的Bundler?

来自分类Dev

如何强制flutter使用旧版本的依赖关系?

来自分类Dev

是否建议使用旧版本的Hyperledger Fabric?

来自分类Dev

在Ubuntu上升级了PHP,但仍在使用旧版本

来自分类Dev

使用旧版本的OpenSSL进行抓取

来自分类Dev

如何使用旧版本的Visual Studio Code?

来自分类Dev

TFS-使用旧版本覆盖文件

来自分类Dev

如何使用旧版本的postgres base?

来自分类Dev

使用旧版本的源代码解决了对addAssociation的承诺

来自分类Dev

项目使用旧版本的 boost 库

来自分类Dev

如何在部署Enterprise App时将Weblogic 12.1.3配置为使用旧版本的Jersey

来自分类Dev

使用ActionCable将Rails应用程序部署到Heroku

来自分类Dev

Android权限:向后兼容。只授予使用我的应用程序旧版本的应用程序(强制执行新版本权限)

来自分类Dev

使用存储在注册表中的应用程序版本号在Inno Setup中检测并卸载旧版本的应用程序

Related 相关文章

  1. 1

    部署后,Rails 4 Capistrano仍使用旧版本

  2. 2

    禁用旧版本iPhone的iPhone应用程序

  3. 3

    如何解决Flutter警告:您的Flutter应用程序是使用旧版本创建的

  4. 4

    使用旧版本的jHipster

  5. 5

    允许使用旧版本的python

  6. 6

    活动使用旧版本的 Firefox

  7. 7

    通过处置旧版本重新启动应用程序

  8. 8

    对旧版本的iPhone禁用iPhone应用程序

  9. 9

    应用程序尝试加载旧版本

  10. 10

    iTunes Connect旧版本的应用程序

  11. 11

    更新我的应用程序的旧版本

  12. 12

    使用新的应用程序图标安装新版本的应用程序后,应用程序显示旧版本的应用程序图标

  13. 13

    Chrome扩展程序升级后,用户仍可以使用旧版本吗?

  14. 14

    强制使用旧版本的vuejs devtools或下载旧版本

  15. 15

    无法使用旧版本的iReport打开Jasper报告

  16. 16

    如何为Ruby项目使用旧版本的Bundler?

  17. 17

    如何强制flutter使用旧版本的依赖关系?

  18. 18

    是否建议使用旧版本的Hyperledger Fabric?

  19. 19

    在Ubuntu上升级了PHP,但仍在使用旧版本

  20. 20

    使用旧版本的OpenSSL进行抓取

  21. 21

    如何使用旧版本的Visual Studio Code?

  22. 22

    TFS-使用旧版本覆盖文件

  23. 23

    如何使用旧版本的postgres base?

  24. 24

    使用旧版本的源代码解决了对addAssociation的承诺

  25. 25

    项目使用旧版本的 boost 库

  26. 26

    如何在部署Enterprise App时将Weblogic 12.1.3配置为使用旧版本的Jersey

  27. 27

    使用ActionCable将Rails应用程序部署到Heroku

  28. 28

    Android权限:向后兼容。只授予使用我的应用程序旧版本的应用程序(强制执行新版本权限)

  29. 29

    使用存储在注册表中的应用程序版本号在Inno Setup中检测并卸载旧版本的应用程序

热门标签

归档